Need DropBoxy to support latest DropBox API

Nov 22, 2011 at 1:58 AM

I downloaded the latest version of source code (13683) and compiled it.  I modified my new project to support the new Callbacks, and am still getting the error during Login: "{\"error\": \"You're using an older version of the Dropbox API with a new API key. Please use the latest version.\"}".

Also, in the DropBoxyEngine, the check for response.ErrorMessage being empty or null is not enough of a check for an error.  The error I receive is returned in the reponse.Content property.

Chuck

Nov 22, 2011 at 2:10 AM

I made an attempt to fix the issue by changing the CONST_VERSION to 1 in Constants.cs, but now I get the error: "{\"error\": \"OAuthError in API v1+. Request mis-signed: Parameter not found: oauth_timestamp\"}"

I give up -- you will have to fix it.

Chuck

Coordinator
Nov 22, 2011 at 5:23 AM

Hey,

 

I'll check this today.

Nov 22, 2011 at 7:37 PM

Just chiming in to say that I have the same issue.

Coordinator
Nov 22, 2011 at 7:53 PM

Hey Guys,

 

I am really overloaded this days. I'll do my best to fix this asap.  Sorry for making you waiting.

Nov 22, 2011 at 9:23 PM

For anyone who might be blocked by this issue, if you happen to have an application that was previously registered with DropBox, you can temporarily use that AppKey and AppSecret while you do your development.  That is what I'm doing.

Chuck